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ABSTRACT 

The current Indian economy is dependent on agriculture to a great extent. Increase in production, 

tends to improve social welfare, particularly in rural areas. This project aims to increase the 

productivity and to reduce the time for seed sowing process and wastage of seeds. Automatic seed 

sowing machine designed and developed, which uses Solar powered DC motors driven by L298N 

driver circuit with Aurdino UNO R3 control kit. An ultrasonic sensor is also installed to detect the 

obstacle in the path and end of each row. 

Keywords: Automation, Agriculture Productivity, Arduino UNO3, L298N Driver, Solar Powered DC 

Motor. 

 

I. Introduction 

An embedded system is a system which is going to do a predefined specified task is the embedded 

system and is even defined as combination of both software and hardware. A general- purpose 

definition of embedded systems is that they are devices used to control, monitor or assist the operation 

of equipment, machinery or plant. "Embedded" reflects the fact that they are an integral part of the 

system. At the other extreme a general-purpose computer may be used to control the operation of a 

large complex processing plant, and its presence will be obvious. All embedded systems are 

including computers or microprocessors. Some of these computers are however very simple systems 

as compared with a personal computer. The very simplest embedded systems are capable of 

performing only a single function or set of functions to meet a single predetermined purpose. In more 

complex systems an application program that enables the embedded system to be used for a 

particular purpose in a specific application determines the functioning of the embedded system. 

The ability to have programs means that the same embedded system can be used for a variety of 

different purposes. In some cases, a microprocessor may be designed in such a way that application 

software for a particular purpose can be added to the basic software in a second process, after which 

it is not possible to make further changes. The applications software on such processors is sometimes 

referred to as firmware. 

The simplest devices consist of a single microprocessor (often called a "chip”), which may itself be 

packaged with other chips in a hybrid system or Application Specific Integrated Circuit (ASIC). Its 

input comes from a detector or sensor and its output goes to a switch or activator which (for example) 

may start or stop the operation of a machine or, by operating a valve, may control the flow of fuel to 
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an engine. 

As the embedded system is the combination 2of both software and hardware Software deals with the 

languages like ALP, C, and VB etc., and Hardware deals with Processors, Peripherals, and Memory. 

 Memory: It is used to store data or address. 

 Peripherals: These are the external devices connected 

 Processor: It is an IC which is used to perform some task 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

FBigure 1: Block diagram oPfeErimphbeerdadlesd system 

 

1. PROPOSED PROJECT SCHEME: 

In this project we are using Arduino uno microcontroller to operate this entire project. We are using 

three different types of sensors to separate the waste by the help of sensors. Dry waste can be 

identified by the IR sensor, wet waste can be detected by the rain sensor and metal objects are 

identified by the metal detector. The L293D motor driver is used to control the motor speed and 

position to place waste in proper container (Dry, Wet and Metal). We can provide power supply 

to this microcontroller and also the DC gear motors to operate the entire project. Power supply can be  

Figure 2: proposed project scheme 
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connected to the each and every hardware module and operated at +5V DC. We can connect these 

sensors at Arduino uno board digital pins and also motor pins are connected to L293D motor IC 

pins, and these pins are connected to the microcontroller. 

Arduino is open-source electronics prototyping platform based on flexible, easy-to-use hardware and 

software. It's intended for artists, designers, hobbyists, and anyone interested in creating interactive 

objects or environments. Arduino can sense the environment by receiving input from a variety of 

sensors and can affect its surroundings by controlling lights, motors, and other actuators. The 

microcontroller on the board is programmed using the Arduino programming language (based on 

Wiring) and the Arduino development environment (based on Processing). Arduino projects can be 

stand-alone or they can communicate with software on running on a computer. 

 

3.1 SOFTWARE IMPLEMENTATION 

3.1.1 Arduino Uno on The Arduino Desktop Ide: 

If you want to program your Arduino Uno while offline you need to install the Arduino Desktop IDE 

The Uno is programmed using the Arduino Software (IDE), our Integrated Development 

Environment common to all our boards. Before you can move on, you must have installed the 

Arduino Software (IDE) on your PC, as explained in the home page of our Getting Started. 

Connect your Uno board with an A B USB cable; sometimes this cable is called a USB printer cable. 

The USB connection with the PC is necessary to program the board and not just to power it up. The 

Uno automatically draw power from either the USB or an external power supply. Connect the 

board to your computer using the USB cable. The green power LED (labelled PWR) should go on. 

3.1.2 Install the board driver 
If you used the Installer, Windows - from XP up to 10 - will install drivers automatically as soon as 

you connect your board. If you downloaded and expanded the Zip Package   or, for some reason, 

the board wasn't properly recognized, please follow the procedure below. 

 

Figure 3: select the board driver 

3.1.3 Select your board type and port: 

You'll need to select the entry in the Tools > Board menu that corresponds to your Arduino board. 

Select the serial device of the board from the Tools | Serial Port menu. This is likely to be COM3 or 

higher (COM1 and COM2 are usually reserved for hardware serial ports). To find out, you can 

disconnect your board and re-open the menu; the entry that disappears should be the Arduino board. 

Reconnect the board and select that serial port. 
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Figure 4: select the type of board 

 
Figure 5: select the comport 

 

3.1.4 Upload the program 

Now, simply click the "Upload" button in the environment. Wait a few seconds - you should see the 

RX and TX leds on the board flashing. If the upload is successful, the message "Done uploading." 

will appear in the status bar. 

Figure 6: sketch the program 

3.1.5 Writing sketches: 

Programs written using Arduino Software (IDE) are called sketches. These sketches are written in the 
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text editor and are saved with the file extension. ino. The editor has features for cutting/pasting and 

for searching/replacing text. The message area gives feedback while saving and exporting and also 

displays errors. The console displays text output by the Arduino Software (IDE), including complete 

error messages and other information. 

1. Inexpensive 

2. Cross-platform 

3. Simple, clearprogramming environment 

4. Opensource and extensible software 

5. Opensource and extensible hardware 

3.1.6 Sketch Book: 

The Arduino Software (IDE) uses the concept of a sketchbook: a standard place to store your 

programs (or sketches). The sketches in your sketchbook can be opened from the File > Sketchbook 

menu or from the Open button on the toolbar 

3.1.6 Libraries: 

Libraries provide extra functionality for use in sketches, e.g. working with hardware or manipulating 

data. To use a library in a sketch, select it from the Sketch > Import Library menu. This will insert 

one or more #include statements at the top of the sketch and compile the library with your sketch. 

Because libraries are uploaded to the board with your sketch, they increase the amount of space it 

takes up. 

 

Figure 7: manage libraries 

Some libraries are included with the Arduino software. Others can be downloaded from a variety of 

sources or through the Library Manager. Starting with version 1.0.5 of the IDE, you do can import a 

library from a zip file and use it in an open sketch. See these instructions for installing a third-party 

library.To install anew library into your Arduino IDE you can use the Library Manager (available 

from IDE version 1.6.2). Open the IDE and click to the "Sketch" menu and then Include Library > 

Manage Libraries. 

3.1.7 Third party hardware: 

Support for third-party hardware can be added to the hardware directory of your sketchbook 

directory. Platforms installed there may include board definitions (which appear in the board menu), 

core libraries, boot loaders, and programmer definitions. To install, create the hardware directory, 

then unzip the third-party platform into its own sub-directory. (Don't use "arduino" as the sub- 

directory name or you'll override the built-in Arduino platform.) To uninstall, simply delete its 

directory [31]. For details on creating packages for third-party hardware, see the Arduino IDE 1.5 
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3rd party Hardware specification 

3.1.8 Burning boot loader 

The boot loader is a small piece of software that allows your Arduino board to communicate with the 

Arduino IDE when you want to upload a sketch. Normally when you want to load a program on a 

microcontroller you need an external programmer, like the Arduino ISP. The boot loader eliminates 

the needs of an external programmer because, the protocol that allows your computer to program the 

flash memory of the AVR is contained inside the boot loader. 

Figure 8: Burn boot loader 

 

4. DESIGN PROCEDURE IN CATIA 

Go to the sketcher workbench create the bed of the waste segregation as per the dimensions after 

create the rectangle in sketcher apply pad in part design workbench. Go to the sketcher workbench 

create the rectangle as per dimensions 60x60mm after apply pad is 1meter after again go to the 

sketcher work bench create the rectangle 750mmx450mm after apply pad is 5mm after create the 

clamp at the bottom of the flat bed and rectangle bar after as shown below figure now create the 

mounting clamp using line and circle apply pad after goto the create the storage device three boxes 

using the sketcher and pad now create the circuit board create the electronic devices after pad now 

go the sketcher create the rectangle apply pad in part design workbench that is battery. Now create 

the joints and screws using sketcher hexagon now create the bearing at motor below the bottom of 

the flat plate after goto the apply pad. 

 

 
Figure 9: Multiple views of model in Catia 
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5. RESULTS AND DISCUSSION: 

Here are the following experimental working Images of all components need to develop a dry 

waste , wet waste and metallic waste using a magnetic system are given. 

Figure 10: final Solar Powered Seed Sowing Machine 

 

6. CONCLUSION 

We have studied well about our project work of solar seed sowing machine. We wish to complete this 

project in a given period. The first step we saw the ratings of components. Later we choose the main 

component dc motor it is depends on the weights of the system. The use of wireless technology in 

agriculture has become increasingly popular in recent years. This technology has the potential to 

revolutionize the way we farm by allowing farmers to monitor and control their operations remotely, 

reduce labour requirements, increase crop yields, and improve overall efficiency. One of the key 

benefits of this technology is that it can significantly reduce the need for manual labour. Farming is a 

labour-intensive industry, and finding reliable and skilled workers can be challenging. With the help 

of wireless technology, farmers can automate many of the routine tasks that were previously done by 

hand, such as plowing, seeding, and harvesting. In addition to reducing labour requirements, wireless 

technology can also help increase crop yields and productivity. By providing farmers with real-time 

data about weather conditions, soil moisture levels, and other factors that affect crop growth, they can 

make more informed decisions about when to plant, fertilize, and harvest. This can help maximize the 

potential of the land and increase profits for farmers. The integration of solar power with wireless 

technology can also help reduce the dependence on traditional energy sources. This can be an eco- 

friendlier option for farming, as it reduces the carbon footprint and overall environmental impact of 

farming operations. Additionally, solar power can provide a reliable source of energy in remote areas 

where traditional electricity sources may not be available. The flexibility of the user interface can also 

make it easier for farmers to adopt new technologies and improve their farming practices. The user 

interface can be designed to be intuitive and easy to use, allowing farmers to quickly and easily control 

their operations using a smartphone or tablet. Finally, the use of wireless technology can help farmers 

stay connected and informed about the status of their crops and farming operations. This can help them 

make more informed decisions and respond quickly to any issues that arise. This can ultimately result 

in higher yields, lower costs, and greater profits for farmers. 
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